Page 1 of 1

KJW P226 Feeding Issue

Posted: Thu May 10, 2012 3:23 pm
by Mark Twain
Having a problem - won't feed correctly. Have looked at mag and tried new mag.

The first shot after you rack the slide is great. But then subsequent shots either roll out the barrel or go about 10 ft.

If you drop the hammer w/ the de-cocker and rack the slide again it shoots fine. As long as you manually rack the slide it shoots.

It's clean and lubricated. I've taken it apart several times and everything runs smooth and looks fine. All feed mating surfaces look fine as well.

Any suggestions would be appreciated. I'm usually pretty good w/ the gbb stuff but this one has me stumped. :?:

Re: KJW P226 Feeding Issue

Posted: Thu May 10, 2012 4:09 pm
by Headkill
Sounds like an issue with the hopup/bucking.

Re: KJW P226 Feeding Issue

Posted: Thu May 10, 2012 4:29 pm
by phridum
I doubt it's the hop/bucking otherwise the problem would be evident occasionally in initial shots too.

On airsoft guns, the external hammer is largely cosmetic for realism. The real hammer that might be causing this issue is internal and strikes the gas release valve on the magazine. Somewhere in the cycle of operations it's getting hung up and causing that hammer to not fully cock and is likely due to some transition mechanism that causes it to go from a Double Action shot to a single action shot.

It sounds as if the slide isn't cycling properly to push that hammer into a fully cocked position, but on a double action shot, the trigger is pushing that hammer back further. Seems like it could be a sear not catching. My thinking is that less hammer travel equals shorter burst of gas causing flaccid shots.

Re: KJW P226 Feeding Issue

Posted: Thu May 10, 2012 6:10 pm
by Mark Twain
Thanks; great ideas - I will look at both.

I'm thinking possbily that it could be a nozzle issue but haven't been able to ( or had time to ) really explore.